Настройка Mikrotik IPTV для Матрикс (Matrix) Донецк ДНР

07 Июля 2019 EVK IT Сервис 3955


Как всегда, обновляем прошивку. Обновление необходимо для того, чтобы установить дополнительный пакет для IPTV (multicast)

Открываем WinBox, заходим в Files. В проводнике распаковываем архив и находим файл multicast-x.xx-mipsbe.npl и перетаскиваем в окошко Files роутера

После этого перезагружаем роутер System Reboot

После перезагрузки пакет установится и должен появиться в System Packages

Открываем Routing IGMP Proxy и добавляем новый интерфейс (нажимаем на кнопочку плюс)

  

В новом интерфейсе, в поле Interface выбираем порт, в который подключен кабель от провайдера Matrix  (ether1) и ставим галочку Upstream

В поле Alternative Subnets указываем подсеть, если вы не знаете какую, то указывайте  0.0.0.0.0/0

Сохраняем настройки нажимая OK

Создаем еще один интерфейс для направления потока на наш внутренний свич

 

Далее в настройках Settings ставим галочку напротив Quick Leave, нужно для быстрого переключения между каналами

 

Настройка Wi-Fi 

В случае, если вы раздаете или собираетесь раздавать IPTV посредством Wi-Fi нужно добавить дополнительные настройки. Для этого открываем по порядку:

После нажатия кнопки Advanced Mode появляются дополнительные параметры: 

В поле WMM Support ставим enabled - включаем поддержку передачи multimedia по Wi-Fi.  

В поле Multicast Helper ставим full. Этот параметр включает отправку мультикаст клиентам, сидящим на Wi-Fi.



Настройка Firewall

Открываем терминал и вводим команды:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether1 protocol=udp

/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

1234 – порт неофициально зарегистрированный для передачи потокового видео и IPTV

ether1 - это интерфейс, на который приходит IPTV от провайдера.

Далее нужно в меню IP выбрать пункт  Firewall и перейти на вкладку Filter Rules.

Мы создали исключающие правила, и чтобы они работали, они должны быть выше запрещающих. Перетягиваем их вверх с помощью мыши.


Другие статьи:
 
evk.ru.com

Компьютерный магазин и сервис
Продажа, ремонт и модернизация компьютеров, ноутбуков, планшетов.
Разработка сайтов.

Контакты

г. Макеевка, ул. Донецкая, 44

(071) 333-73-10

(066) 662-50-71